TransDEM Forum

TransDEM News, Support, Hints and Resources
It is currently 23 Nov 2017 06:18

All times are UTC + 1 hour




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: 01 Jul 2017 08:41 
Offline

Joined: 28 Mar 2011 03:35
Posts: 67
Without going into too much public detail I've been doing a few tests for N3V to try and establish why performance has plunged so much working in Surveyor with SP2 as opposed to SP1 HF4. I now have both versions running and whereas Surveyor will run without any drama in SP1 HF4 put the same Transdem route in SP2 and the hardware is going into meltdown, fan whirring at full speed, memory leaks (track and terrain not redrawing after editing or CTD/freeze on saving).

Now I know my Transdem version isn't the most up to date one as I'm still extracting routes in TS12 format and putting them into TANE. It also appears N3V have changed the file format for routes moving forward into SP2. So the question has to be asked, could the sudden issues being encountered be either a direct or indirect result of how SP2 is reading DEM based or Transdem routes/data as opposed to how the earlier versions worked? Of course N3V may already be in dialogue with Roland regarding this and I'm not wanting anyone to breach NDA's etc., but it is important to try and work positively to resolve what might have gone wrong rather than "whinging" on the main N3V forum.


Top
 Profile  
 
PostPosted: 01 Jul 2017 21:29 
Offline

Joined: 05 Jan 2011 16:45
Posts: 1057
Not quite sure which version you have, but original T:ANE only made marginal changes to the route file formats. That included a replacement for old lighting data structure, from TRS2004 days. The previous lighting environment now showed up in psychedelic blue. Was fixed in TransDEM 2.6. However, SP2 is a totally different story, because almost every piece of data will now be stored in per-baseboard files. If have run a couple of preliminary tests with blank routes right out of the TransDEM route generator and didn't find any issues on the Trainz side so far. But that's rather superficial observation at the moment. I haven't started yet to address the new file formats. Another update to TransDEM 2.6 will come first, dealing with the challenges of 1m LIDAR DEMs and the enormous amount of data that comes with them. Plus a few new DEM data sources from the US, Germany, Luxembourg, Austria and Victoria/Australia.


Top
 Profile  
 
PostPosted: 02 Jul 2017 08:12 
Offline

Joined: 28 Mar 2011 03:35
Posts: 67
I will check my latest version but the latest exporter is for TS12, not TANE.

I think there are fundamental issues with the changes in SP2 as testified on the N3V forums and to some extent almost as if they reverted to a much earlier version, but that's a debate for over there rather than here. However I can still relate that a ~100km route extracted to the "usual" 6 - 7 baseboards either side of the track line, purrs along sweetly in SP1 HF4 while SP2 has the hardware screaming and all sorts of buggy behavior. I just hope N3V aren't attempting to make use of DEM based routes a scapegoat for their own shortcomings.

Edit: I'm on 2.5.0.0


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron

Imprint

Powered by phpBB® Forum Software © phpBB Group